Horizon slowness
Incident Report for HTK
Resolved
The issue has now been resolved. We apologise for any inconvenience this has caused.
Posted Oct 12, 2020 - 14:25 BST
Investigating
There is currently an issue with slowness when using Horizon or the Horizon API. We are currently investigating this issue with the highest priority.
Posted Oct 12, 2020 - 09:51 BST
This incident affected: API (UK) and Horizon Europe.